kostenloser Webspace werbefrei: lima-city


Problem bei Apache2-Installation unter Ubuntu

lima-cityForumHeim-PCSoftware

  1. Autor dieses Themas

    w*o

    Hallo!

    Ich möchte den Apache2 unter Ubuntu installieren, allerdings funktioniert es nicht. Ich mache das über die Konsole, aber es kommt immer zu einer Fehlermeldung bei 3 abhängigen Paketen:

    adpc@adpc:~$ sudo apt-get install apache2
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Status-Informationen einlesen... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
    apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
    Vorgeschlagene Pakete:
    apache2-suexec apache2-suexec-custom
    Die folgenden NEUEN Pakete werden installiert:
    apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
    0 aktualisiert, 9 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    Es müssen noch 0B von 3.328kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 10,1MB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]? j
    Wähle vormals abgewähltes Paket libapr1.
    (Lese Datenbank ... 290662 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacke libapr1 (aus .../libapr1_1.3.8-1build1_i386.deb) ...
    Wähle vormals abgewähltes Paket libaprutil1.
    Entpacke libaprutil1 (aus .../libaprutil1_1.3.9+dfsg-3build1_i386.deb) ...
    Wähle vormals abgewähltes Paket libaprutil1-dbd-sqlite3.
    Entpacke libaprutil1-dbd-sqlite3 (aus .../libaprutil1-dbd-sqlite3_1.3.9+dfsg-3build1_i386.deb) ...
    Wähle vormals abgewähltes Paket libaprutil1-ldap.
    Entpacke libaprutil1-ldap (aus .../libaprutil1-ldap_1.3.9+dfsg-3build1_i386.deb) ...
    Wähle vormals abgewähltes Paket apache2.2-bin.
    Entpacke apache2.2-bin (aus .../apache2.2-bin_2.2.14-5ubuntu8_i386.deb) ...
    Wähle vormals abgewähltes Paket apache2-utils.
    Entpacke apache2-utils (aus .../apache2-utils_2.2.14-5ubuntu8_i386.deb) ...
    Wähle vormals abgewähltes Paket apache2.2-common.
    Entpacke apache2.2-common (aus .../apache2.2-common_2.2.14-5ubuntu8_i386.deb) ...
    Wähle vormals abgewähltes Paket apache2-mpm-worker.
    Entpacke apache2-mpm-worker (aus .../apache2-mpm-worker_2.2.14-5ubuntu8_i386.deb) ...
    Wähle vormals abgewähltes Paket apache2.
    Entpacke apache2 (aus .../apache2_2.2.14-5ubuntu8_i386.deb) ...
    Verarbeite Trigger für man-db ...
    Verarbeite Trigger für ufw ...
    Verarbeite Trigger für ureadahead ...
    Richte libapr1 ein (1.3.8-1build1) ...

    Richte libaprutil1 ein (1.3.9+dfsg-3build1) ...

    Richte libaprutil1-dbd-sqlite3 ein (1.3.9+dfsg-3build1) ...
    Richte libaprutil1-ldap ein (1.3.9+dfsg-3build1) ...
    Richte apache2.2-bin ein (2.2.14-5ubuntu8) ...
    Richte apache2-utils ein (2.2.14-5ubuntu8) ...
    Richte apache2.2-common ein (2.2.14-5ubuntu8) ...
    ERROR: Module reqtimeout does not exist!
    dpkg: Fehler beim Bearbeiten von apache2.2-common (--configure):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von apache2-mpm-worker:
    apache2-mpm-worker hängt ab von apache2.2-common (= 2.2.14-5ubuntu8); aber:
    Paket apache2.2-common ist noch nicht konfiguriert.
    dpkg: Fehler beim Bearbeiten von apache2-mpm-worker (--configure):
    Abhängigkeitsprobleme - lasse es unkonfiguriert
    No apport report written because the error message indicates its a followup error from a previous failure.
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von apache2:
    apache2 hängt ab von apache2-mpm-worker (= 2.2.14-5ubuntu8) | apache2-mpm-prefork (= 2.2.14-5ubuntu8) | apache2-mpm-event (= 2.2.14-5ubuntu8) | apache2-mpm-itk (= 2.2.14-5ubuntu8); aber:
    Paket apache2-mpm-worker ist noch nicht konfiguriert.
    Paket apache2-mpm-prefork ist nicht installiert.
    Paket apache2-mpm-event ist nicht installiert.
    Paket apache2-mpm-itk ist nicht installiert.
    apache2 hängt ab von apache2.2-common (= 2.2.14-5ubuntu8); aber:
    Paket apache2.2-common ist noch nicht konfiguriert.
    dpkg: Fehler beim Bearbeiten von apache2 (--configure):
    Abhängigkeitsprobleme - lasse es unkonfiguriert
    Verarbeite Trigger für libc-bin ...
    No apport report written because the error message indicates its a followup error from a previous failure.
    ldconfig deferred processing now taking place
    Fehler traten auf beim Bearbeiten von:
    apache2.2-common
    apache2-mpm-worker
    apache2
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    Kann mir jemand helfen? Bin noch kein fortgeschrittener Ubuntu-User, deswegen :confused:

    Vielen Dank schon mal! :)
  2. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

  3. dieseseitehier

    dieseseitehier hat kostenlosen Webspace.

    hast du genug freien Speicherplatz auf der Festplatte?
  4. Autor dieses Themas

    w*o

    Natürlich habe ich das! ca. 50 GB sind noch frei!
  5. Also, das Problem kenne ich...
    Ich habe in der Kommandozeile eingegeben:
    sudo dpkg --purge --force-remove-reinstreq apache2.2-common

    --> dies entfernt komplett alles von apache2
    danach können sie noch einmal versuchen apache2 zu installieren.
    In den meisten Fällen ausreichend!

    MfG Min

    Nebenbei: welches Ubuntu haben sie?

    Beitrag zuletzt geändert: 21.6.2010 10:11:17 von minalex
  6. Autor dieses Themas

    w*o

    minalex schrieb:
    Also, das Problem kenne ich...
    Ich habe in der Kommandozeile eingegeben:
    sudo dpkg --purge --force-remove-reinstreq apache2.2-common

    --> dies entfernt komplett alles von apache2
    danach können sie noch einmal versuchen apache2 zu installieren.
    In den meisten Fällen ausreichend!

    MfG Min

    Nebenbei: welches Ubuntu haben sie?


    Der befehl sudo dpkg --purge --force-remove-reinstreq apache2.2-common entfernt nur das Paket apache2.2-common. Aber ich werde mal den Paketnamen anpassen, vielleicht funktioniert es.

    Ich verwende ein modifiziertes Ubuntu Studio (Ubuntu 10.04 mit Echtzeitkernel). Aber das müsste mit dem Apache2 kompatibel sein.

    EDIT:
    Ich habe es ausprobiert, es kommt trotzdem der gleiche Fehler!

    Beitrag zuletzt geändert: 21.6.2010 10:22:43 von who
  7. kochmarkus

    Co-Admin Kostenloser Webspace von kochmarkus

    kochmarkus hat kostenlosen Webspace.

    Hau Apache mit dem genannten Befehl doch noch mal runter, mach danach ein sudo apt-get update und sudo apt-get upgrade und versuch danach nochmal Apache zu installieren.
  8. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

Dir gefällt dieses Thema?

Über lima-city

Login zum Webhosting ohne Werbung!