kostenloser Webspace werbefrei: lima-city


Hilfe bei einer EXEL FORMEL

lima-cityForumHeim-PCSoftware

  1. Autor dieses Themas

    m***e

    Ich suche eine Exel formel nit der ich feststellen kann ob in einer Zelle etwas steht und die Zellen in dennen etwas steht zusammen z?hlen kann.

    =WENN(ISTTEXT(A1);1;0)

    So geht es f?r eine Zelle aber wie geht es f?r mehrere???
  2. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

  3. mecle schrieb:
    Ich suche eine Exel formel nit der ich feststellen kann ob in einer Zelle etwas steht


    Geht doch mit ISTLEER()

    mecle schrieb:
    Ich suche eine Exel formel nit der ich feststellen kann ob in einer Zelle etwas steht und die Zellen in dennen etwas steht zusammen z?hlen kann.


    Doch daf?r w?rde ich lieber ISTZAHL() und ANZAHL() nehmen

    Zieh mal die Datei hoch, dann mach ich dir das.

    Beitrag ge?ndert am 6.06.2006 16:07 von wilhelm
  4. einfach addieren, also unten hin, und auf diesen summenbutton klicken, fertig. wenn nichts drinsteht, wird auch nichts addiert, ist ja klar. ansonsten kannst du dir auch mit einem vba-makro behelfen:

    spalte soll a sein, man m?chte alle bis zur 15. zeile addieren, ergebnis kommt in die 16:

    Public Sub lol()

    Dim i As Integer

    Range("A16").FormulaR1C1 = "0"

    For i = 1 To 15
    If Range("A" & i).FormulaR1C1 <> "" Then
    If IsNumeric(Range("A" & i).FormulaR1C1) Then _
    Range("A16").FormulaR1C1 = CDbl(Range("A16").FormulaR1C1) + CDbl(Range("A" & i).FormulaR1C1)
    End If
    Next i

    End Sub

    allerdings musst du diese sub immer wieder ausf?hren, um eine aktuelle summe zu erhalten. du kannst den inhalt der sub auch in ein makro schreiben und das mit einer tastenkombination aufrufen.

    falls es noch probleme geben sollte:
    icq: 248213336

    viele gr??e
    philipp keck
  5. Autor dieses Themas

    m***e


    mecle schrieb:
    Ich suche eine Exel formel nit der ich feststellen kann ob in einer Zelle etwas steht


    Geht doch mit ISTLEER()

    mecle schrieb:
    Ich suche eine Exel formel nit der ich feststellen kann ob in einer Zelle etwas steht und die Zellen in dennen etwas steht zusammen z?hlen kann.


    Doch daf?r w?rde ich lieber ISTZAHL() und ANZAHL() nehmen

    Zieh mal die Datei hoch, dann mach ich dir das.

    Beitrag ge?ndert am 6.06.2006 16:07 von wilhelm


    Danke kannst du vileicht einfach ne neue hochladen weil ich habe die Datei noch nicht fertig und sie sollte auch nicht einfach so im inet stehen da sie privat ist.
  6. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

Dir gefällt dieses Thema?

Über lima-city

Login zum Webhosting ohne Werbung!