kostenloser Webspace werbefrei: lima-city


Firefox muckt auf!

lima-cityForumDie eigene HomepageHomepage Allgemein

  1. Autor dieses Themas

    jacer

    Kostenloser Webspace von jacer

    jacer hat kostenlosen Webspace.

    also habe jez bei meiner website einen mouseover effekt mit eingebaut. funktionniert auch alles ganz gut nur der firefox spinnt. der ?bergeht diesen effekt bei mir komplett.
    hier der link da k?nnt ihr euch ja den quellcode anschauen:
    http://jacer.milten.lima-city.de/Projekte/GIA/pages/

    hoffe ihr kennt eine l?sung, da es eine clan seite wird und nat?rlich von sehr vielen leuten auch mit firefox besucht wird.
  2. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

  3. Hi,
    wo soll der mouseover effekt denn zu sehen sein?
    Bei der Navigation auf der linken Seite???

    Ich benutze ja Firefox und sehe keinen MouseOver-Effekt!
    Vielleicht probierst du mal das Design mit div-Containern aufzusetzen und probierst da mal den Mouseover-Effekt anzuwenden.
  4. Autor dieses Themas

    jacer

    Kostenloser Webspace von jacer

    jacer hat kostenlosen Webspace.

    ja am besten schaust du dir das ganze mal kurzmit dem IE an.
    dann siehste, dass der mouseover effekt links bei der navi sein soll
  5. Hi,
    ich habe das gerade mal selber ausprobiert.
    Hier mal die Quellcodes:

    index.html / index.php
    <html>
    <head>
    <title>Untitled</title>
    <link rel="stylesheet" type="text/css" href="style.css">
    </head>
    <body>
    <table border="1" cellpadding="0" cellspacing="0">
    <tr>
    <td class="test">Hallo ihr</td>
    </tr>
    </table>
    </body>
    </html>


    style.css
    td.test:hover {
    background-color:red;
    }


    Bei mir wird die Hintergrundfarbe bei ?berfahren mit der Maus auf Rot gewechselt im Firefox

    Vllt. postest du mal etwas Quellcode, :wink: dann kann man evtl. besser helfen!
  6. ich habs mal probiert, und ich hab ka wieso es nicht geht.
    k?nntest du das mal mit div container und nicht mit tabellen machen, dann w?re das schon viel ?bersichtlicher.
    ich habs mal im IE angeguckt und ich wei?, was fehlt, n?mlich dieser rote punkt.

    -AlieNDWarf
  7. Hier nochmal der Versuch mit deinen Bildern:
    index.php
    <html>
    <head>
    <title>Untitled</title>
    <link rel="stylesheet" type="text/css" href="style.css">
    </head>
    <body>
    <table border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td class="test" width="180" height="19" align="center">Hallo ihr</td>
    </tr>
    </table>
    </body>
    </html>


    style.css
    td.test {
    background:url("navi_button.jpg");
    }

    td.test:hover {
    background:url("navi_button2.jpg");
    }


    Die URL zum testen ist folgende:
    http://guidoloerks.dyndns.org/webhosting/user/jacer/index.php
  8. Autor dieses Themas

    jacer

    Kostenloser Webspace von jacer

    jacer hat kostenlosen Webspace.

    ja genau dieser "rote punkt" wird halt im firefox nicht angezeigt. ich werde das ganze nicht in div container packn weil ich tabellen sch?ner finde^^
    ich weiss es ist nich so gerne gesehen weil alle meinen das w?re scheisse aba ich arbeite gerne mit tabellen. naja egal. ich versuche dass mal so wie du gesagt hast hast privateflash


    EDIT:
    so ich habe es probiert und es funktioniert. somit hat sich das problem erledigt. ich danke euch:wink:

    EDIT2:
    STOP NEIN ALLES ZUR?CK. es geht jez zwar im firefox aber daf?r nicht mehr im IE:mad: was macht ich jetzt?? muss ich jez beide methoden in den quellcode einf?gen damit es auch in allen browsern angezigt wird?? also trotzdem in der td onmouseover und onmouseout bestimmen trotz dass das schon mit css angegeben ist??
  9. Keine Ursache. Nur bl?hen div-container den Quellcode nicht so auf und es kann auch ?bersichtlicher sein ;)

    Falls du noch Probleme hast. Einfach posten. Du wei?t ja wie das hier l?uft ^^
  10. t*****t

    Auf Antrag eines Mods geschlossen.


    Edit: Der User hat die ?ffnung des threads beantragt, da das Thema f?r ihn noch nicht abgeschlossen gewesen ist. Deshalb vorerst wieder ge?ffnet.
  11. Hallo hallo ^^
    Hier erneut die L?sung:
    index.html / index.php
    <html>
    <head>
    <title>Untitled</title>
    <link rel="stylesheet" type="text/css" href="style.css">
    </head>
    <body>
    <table border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td width="180" height="19" align="center"><a href="#">Testlink</a></td>
    </tr>
    </table><br><br><br>
    <a href="#">Testlink</a>
    </body>
    </html>


    style.css
    td {
    background:url("navi_button.jpg");
    }

    td:hover, td.hover {
    background:url("navi_button2.jpg");
    }

    td {
    behavior:url("hover.htc");
    }

    a:hover {
    color:#BF0000;
    }


    Das wichtige und neue ist jetzt eigentlich nur in der *.CSS Datei zu finden.
    F?r den IE ben?tigst du die Datei "hover.htc", die du hier runterladen kannst:
    http://www.hszk.bme.hu/~hj130/css/list_menu/hover/hover.htc

    Die legst du in irgendeinem Verzeichnis auf deinem Server ab und verlinkst sie dann noch entsprechend.
    Diese Datei, hover.htc, wird dazu ben?tigt um beim IE auch anderen Objekten z.B. die hover Funtktion zuweisen zu k?nnen und nicht wie gewohnt nur den Links!!!

    Ich wei? schon warum ich den IE nicht mehr benutze :biggrin:

    Hoffe ich konnte dir helfen.

    Edit -> Jetzt funktioniert die hover-Funktion sowohl beim Netscape, Firefox und auch beim IE :cool:
  12. Also ich bin jetzt komplett verwirrt.

    Ich sehe diesen MousOver Effekt nur im Firefox aber nicht im IE.

    So wie ich das bis jetzt gelesen habe sollte es aber gerade anderst herum sein, oder sehe ich da was falsch?

    Gru? Tobi
  13. Autor dieses Themas

    jacer

    Kostenloser Webspace von jacer

    jacer hat kostenlosen Webspace.



    ttobsen schrieb:
    Also ich bin jetzt komplett verwirrt.

    Ich sehe diesen MousOver Effekt nur im Firefox aber nicht im IE.

    So wie ich das bis jetzt gelesen habe sollte es aber gerade anderst herum sein, oder sehe ich da was falsch?

    Gru? Tobi


    ja das war am anfang das problem. doch mit der l?sung war es dann genau umgekehrt. also es ging dann im firefox aber nicht mehr im IE. etwas verwirrend ich weiss :biggrin:
    und mit dieser l?sung soll es jetzt wohl bei allen browser fuktionieren, was ich jetzt gleich mal testen werde:wink:
  14. Hi Tobi.
    Wie gesagt hat der IE ein paar kleine *lol* Macken.

    Die hover-Funktion gibt es beim IE normalerweise NUR f?r Links.
    Allerdings gibt es inzwischen Methoden, unter anderem die von mir gepostete, um dies zu ?ndern.
    Bei Firefox, Mozilla, Netscape, etc. gibt es dieses Problem nicht.

    Microschrott eben *schulterzuck*
  15. Autor dieses Themas

    jacer

    Kostenloser Webspace von jacer

    jacer hat kostenlosen Webspace.



    privateflash schrieb:
    Hi Tobi.
    Wie gesagt hat der IE ein paar kleine *lol* Macken.

    Die hover-Funktion gibt es beim IE normalerweise NUR f?r Links.
    Allerdings gibt es inzwischen Methoden, unter anderem die von mir gepostete, um dies zu ?ndern.
    Bei Firefox, Mozilla, Netscape, etc. gibt es dieses Problem nicht.

    Microschrott eben *schulterzuck*


    ja ich benutze den IE auch nicht. aber das mindert ja die qualit?t der seite wenn man einfach sagt: tut mir leid jungs, aber ihr muesst euch schon den ff laden sonst k?nnt ihr die seite nich besuchen. deshlab muss man halt versuchn ne l?sung f?r alle zu finden:wink:
  16. Schon ge?ndert und probiert???
    Gib mal bescheid wenn du es ge?ndert haben solltest.
  17. Autor dieses Themas

    jacer

    Kostenloser Webspace von jacer

    jacer hat kostenlosen Webspace.

    srry f?r doppelpost aba wirkt sonst so durcheinander.

    also es geht immernoch nich. mein css sieht jez folgenderma?en aus:


    <style type="text/css">
    a
    {text-decoration: none ;
    font-size: 11pt ;
    font-weight: bold ;
    }

    a:hover
    {color: #BF0000
    }

    td.navi
    {background:url("http://jacer.milten.lima-city.de/Projekte/GIA/grafik/navi_button.jpg");
    behavior:url("http://jacer.milten.lima-city.de/hover.htc");
    }

    td.navi:hover {background:url("http://jacer.milten.lima-city.de/Projekte/GIA/grafik/navi_button2.jpg");
    }
    </style>


    und dann die tabelle:


    <td class="navi" width="180" height="19" valign="top" align="center">
    <table width="70%" cellspacing="0" cellpadding="0">
    <tr><td width="100%" valign="top">
    <a href="LINK">Link</a>
    </td></tr>
    </table>


    ich benutze Phase5 und der gibt mir folgende Fehlermeldung aus:


    In dem Skript auf der Seite ist ein fehler aufgetreten.
    Zeile: 0
    Zeichen 0
    Fehler Access is denied to http://jacer.milten.lima-city.de/hover.htc

  18. Ein Beweis das es funktioniert:

    http://privateflash.milten.lima-city.de/jacer/index.php

    Es k?nnte sein das die Grafiken etwas l?nger laden aber kA warum.
  19. @ jacer

    Auf deiner Seit funktioniert es doch, jedenfalls bei mir und ich benutze auch firefox.
  20. Autor dieses Themas

    jacer

    Kostenloser Webspace von jacer

    jacer hat kostenlosen Webspace.



    boyman schrieb:
    @ jacer

    Auf deiner Seit funktioniert es doch, jedenfalls bei mir und ich benutze auch firefox.


    mal den ganzen thread lesen bevor man schreibt. zur zeit liegt das problem vor dass es im IE nicht funzt. dass es im fireofx geht wissen wir
  21. So, ?nder das in deiner Datei ab (ist nur der CSS Teil) und f?ge die "hover.htc" in dieses Verzeichnis ein:
    http://jacer.milten.lima-city.de/Projekte/GIA/pages/

    Damit sollte es jetzt eigentlich klappen.

    <style type="text/css">
    a
    {text-decoration: none ;
    font-size: 11pt ;
    font-weight: bold ;
    }
    a:hover
    {color: #BF0000;
    }
    td.navi
    {background:url("http://jacer.milten.lima-city.de/Projekte/GIA/grafik/navi_button.jpg");
    }
    td.navi:hover, td.naviHover
    {background:url("http://jacer.milten.lima-city.de/Projekte/GIA/grafik/navi_button2.jpg");
    }
    td
    {behavior:url("hover.htc");
    }
    </style>
  22. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

Dir gefällt dieses Thema?

Über lima-city

Login zum Webhosting ohne Werbung!