kostenloser Webspace werbefrei: lima-city


Kryptische Zeichen NUR in Firefox

lima-cityForumDie eigene HomepageHTML, CSS & Javascript

  1. Autor dieses Themas

    flockhaus

    Kostenloser Webspace von flockhaus

    flockhaus hat kostenlosen Webspace.

    Ich habe eine Site pro forma zusammen geschmissen und säuber gerade den Quellcode. Ein Problem, was ich par tout nicht in den Griff bekomme:

    Der Firefox gibt mir eine komische Zeichenkette am oberen Rand aus und verrutscht somit das ganze Layout. Bei jedem anderen Browser allerdings gibt es dieses Problem nicht.

    alternativ:Site im Firefox öffnen und voila...

    Hat jemand einen guten Rat?


    Beitrag geändert: 23.9.2008 9:30:53 von flockhaus
  2. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

  3. Schau mal in den Quelltext...
    Da sind die komischen Zeichen direkt am Anfang.
    Die sind dir wohl irgendwie dazwischen gerutscht. Mach sie einfach im Filemanger weg.

    Ansonsten sehen die ganzen Umlaute ziehmlich seltsam aus in Opera.
    Stell mal
    <meta http-equiv=\"Content-Type\" content=\"text/html ; charset=iso-8859-1\" />

    auf

    <meta http-equiv=\"Content-Type\" content=\"text/html ; charset=utf-8\" />

    um. Das sollte das Problem beheben.
  4. Autor dieses Themas

    flockhaus

    Kostenloser Webspace von flockhaus

    flockhaus hat kostenlosen Webspace.

    Das ist ja der Witz. Diese Zeichen stehen nicht im orginalen Quellcode, 100%ig sicher. Nur Firefox gibt es auch bei der Quelltextausgabe ebenfalls an.

    Habe erstmal nur die Index auf charset=utf-8 gestellt, aber es ändert sich nichts..

    www.werkelchen.de/index.html
  5. c*a

    Kann ich bestätigen, der Internet Explorer gibt mir die Zeichen im Quelltext nicht an FF schon :confused:
  6. c*a

    Vll hast du die Codierung in deinem Editor falsch eingestellt

    http://de.wikipedia.org/wiki/Byte_Order_Mark

    Beitrag geändert: 19.9.2007 23:27:33 von cga
  7. thomasba

    Co-Admin Kostenloser Webspace von thomasba

    thomasba hat kostenlosen Webspace.

    Wenn du die Sonderzeichen, wie ä,ö,ü,ß genauso im Quellcode geschrieben hast ersetz mal
    ä mit &amp;auml;
    ö mit &amp;ouml;
    ü mit &amp;uuml;
    ß mit &amp;szlig;
    das behebt zumindest das Problem mit diesen Sonderzeichen.

    Achso, diese komischen zeichen gibt es bei mir hier auch:
    http://www.lima-city.de/usercp.php :D

    Beitrag geändert: 19.9.2007 23:59:51 von thomasba
  8. Autor dieses Themas

    flockhaus

    Kostenloser Webspace von flockhaus

    flockhaus hat kostenlosen Webspace.

    Die Umlaute habe ich im Testtext noch nicht als HTML-Char Entities umgeschrieben, aber daran liegt es nicht.

    Achso, diese komischen zeichen gibt es bei mir hier auch:
    http://www.lima-city.de/usercp.php

    Ja, tritt bei mir auch auf. Allgemein hat das mittlerweile wieder alte Lima-Layout so seine Fehler..


    Vll hast du die Codierung in deinem Editor falsch eingestellt
    http://de.wikipedia.org/wiki/Byte_Order_Mark

    Es lag tatsächlich an der Codierung. UTF-8 ohne BOM und schon bin ich zufrieden. Vielen Dank, Problem gelöst. Vielleicht schauen Lima-Betreiber auch mal nach dem Rechten...

    :shy:

    Beitrag geändert: 20.9.2007 8:42:16 von flockhaus
  9. Hi!
    Hab das gleiche Problem mit den Zeichen:
    Wie kann ich das denn ändern?
    Hatte letztens eine Seite gemacht, bei der das Problem nicht bestand.
    Nach der Neugestaltung traten jetzt diese komischen Zeichen auf, ohne dass ich etwas grundlegendes verändert habe.


    Alex
  10. Autor dieses Themas

    flockhaus

    Kostenloser Webspace von flockhaus

    flockhaus hat kostenlosen Webspace.

    In deinem Text-Editor dürftest du eine entsprechende Einstellung vornehmen können. Wichtig: UTF-8 no BOM!

    Dann die Datei in dieser Codierung abspeichern und anschauen :thumb:

    Beitrag geändert: 20.9.2007 12:06:33 von flockhaus
  11. Wie geht denn das? Kann diese Option nicht finden.
    Hier gibt\'s nur UTF-8 und noch haufenweise andere Möglichkeiten.
    Aber \"no BOM\" steht da nicht. Kann ich vielleicht auch eine andere Codierung nutzen?
  12. Autor dieses Themas

    flockhaus

    Kostenloser Webspace von flockhaus

    flockhaus hat kostenlosen Webspace.

    Gute Frage.. Was verwendest du denn für einen Editor? \"Gute\" Editoren müssten doch eine Möglichkeit haben, oder?
  13. Ich hatte schon in anderen Foren gefragt und da wurde mir für Linux der \"Bluefish\"-HTML-Editor empfohlen. Bin auch sehr zufrieden damit. Es wird alles schön übersichtlich dargestellt. Allerdings besteht jetzt dieses Problem.
  14. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

Dir gefällt dieses Thema?

Über lima-city

Login zum Webhosting ohne Werbung!