kostenloser Webspace werbefrei: lima-city


Subdomain übernimmt Font nicht

lima-cityForumDie eigene HomepageHTML, CSS & Javascript

  1. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    Hallo,

    Ich habe ein Problem mit meiner Titel-Schriftart. Unter der Orginal Domain https://swportfolio.lima-city.de/wordpress2/ wird sie richtig dargestellt. Aber ruft man die Seite unter der Subdomain https://swportfolio.4lima.de/ auf, ist die Font eine ganz andere. Ich bin mit meinem Latein langsam am Ende, leider habe ich nicht so viel Ahnung, weshalb ich mich an dieses Forum wende. Ich weiss nicht was ich falsch gemacht habe und Bitte um Hilfe. :rolleyes:



    Beitrag zuletzt geändert: 14.9.2015 8:54:58 von swportfolio
  2. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

  3. Du verweist im CSS auf eine andere Subdomain.

    Heißt also, wenn du auf >> swportfolio.4lima << auch die Font laden möchtest, musst du im CSS für diese eine Subdomain auch auf

    @font-face {src: url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot");
    zugreifen.

    http://www.agoradesign.at/blog/cross-domain-verwendung-von-font-face-im-firefox-ermoeglichen




    Beitrag zuletzt geändert: 14.9.2015 9:58:37 von javaphp
  4. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    Danke für die Antwort.

    Muss ich dafür eine neue Datenbank anlegen oder kann ich meine bisherige weiter nutzen?
  5. swportfolio schrieb:
    Muss ich dafür eine neue Datenbank anlegen oder kann ich meine bisherige weiter nutzen?


    Normalerweise hat eine Datenbank mit dem CSS File nichts zu tun.

    Du musst nur deine CSS Datei so abändern, dass die Links in der Datei mit dem besuchten Domainnamen übereinstimmen.
  6. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    javaphp schrieb:
    swportfolio schrieb:
    Muss ich dafür eine neue Datenbank anlegen oder kann ich meine bisherige weiter nutzen?


    Normalerweise hat eine Datenbank mit dem CSS File nichts zu tun.

    Du musst nur deine CSS Datei so abändern, dass die Links in der Datei mit dem besuchten Domainnamen übereinstimmen.


    Ich habe es im Stylesheet geändert, aber es tut sich nichts.

    @font-face {
    src: url("https://swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot");
    src: url("font/League_Gothic-webfont.eot?#iefix") format("embedded-opentype"),
    url("font/League_Gothic-webfont.woff") format("woff"),
    url("font/League_Gothic-webfont.ttf") format("truetype"),
    url("font/League_Gothic-webfont.svg#LeagueGothicRegular") format("svg");
    font-family: "LeagueGothicRegular";
    font-weight: normal;
    font-style: normal;

    Die Sub-Domain greift auf den Ordner Wordpress2 zu, SSL ist aktiviert. Ich merke gerade das die Domain generell Probleme hat die Seite anzuzeigen, wenn man sie nicht direkt zwei-dreimal aktualisiert.

    Vorher hatte ich die Seite unter einer Domain von Strato weitergeleitet, da gab es keine Ladeprobleme aber eben das Font Problem. Ich bin auch gerade dabei mit einer neuen Domain auf Strato umzuziehen, mit dieser wollte ich das Portfolio Verlinken. Jetzt mach ich mir sorgen das es dort auch zu diesem Problem kommt. Dort besitze ich auch keine Datenbank, vielleicht sollte ich den Umzug rückgängig machen und die (Haupt) Domain auf lima anlegen?
    Aber daran kann es doch nicht scheitern..



    Beitrag zuletzt geändert: 14.9.2015 10:45:43 von swportfolio
  7. hallo swportfolio,


    du hast zwar wie es javaphp beschrieben hatte die quellenangabe der ersten schriftarten-referenz geändert, die restlichen quellenangaben (da schriftarten für die verschiedenen browser/bertiebssysteme in unterschiedlichen formaten zur verfügung gestellt werden müssen) zeigen allerdings noch auf einen relativen pfad der mit "font/" beginnt, vielleicht solltest du auch diese quellenangaben wie die erste absolut machen (also mit "https://swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/" vor dem "font/")...


    lg hechma
  8. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    hechma schrieb:
    hallo swportfolio,


    du hast zwar wie es javaphp beschrieben hatte die quellenangabe der ersten schriftarten-referenz geändert, die restlichen quellenangaben (da schriftarten für die verschiedenen browser/bertiebssysteme in unterschiedlichen formaten zur verfügung gestellt werden müssen) zeigen allerdings noch auf einen relativen pfad der mit "font/" beginnt, vielleicht solltest du auch diese quellenangaben wie die erste absolut machen (also mit "https://swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/" vor dem "font/")...


    lg hechma


    Ok, Danke. Das werde ich mal probieren. Aber was mache ich dann mit der Domain bei Strato? unter dieser Domain wollte ich die Seite laufen lassen und verlinken, dort habe ich aber keine Datenbank oder ähnliches nur die Domain und DNS Einstellung :/ Da ich mit dieser Domain noch im Umzug stecke, könnte ich den "providerwechsel" ablehnen. Und mit dieser Domain auf lima umziehen. Aber es kann doch nicht an der Datenbank liegen, ich hatte sonst nie Probleme. Ich bin wirklich ratlos :/

    Ich habe es geändert und nun ist die Schriftart auf beiden Seiten bei lima besch***. :frust:


    Beitrag zuletzt geändert: 14.9.2015 11:44:08 von swportfolio
  9. Egal wo du deine Domain nachher hast, sollte es zu keinem Problem in der Darstellung der Fonts geben.

    Dein Problem ist nur die richtige Verlinkung der Fonts:

    Anstelle von:

    @font-face {
    	src: url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot");
    	src: url("font/League_Gothic-webfont.eot?#iefix") format("embedded-opentype"),
    	     url("font/League_Gothic-webfont.woff") format("woff"),
    	     url("font/League_Gothic-webfont.ttf") format("truetype"),
    	     url("font/League_Gothic-webfont.svg#LeagueGothicRegular") format("svg");


    Folgendes verwenden:

    @font-face {
    	src: url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot");
    	src: url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot?#iefix") format("embedded-opentype"),
    	     url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.woff") format("woff"),
    	     url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.ttf") format("truetype"),
    	     url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.svg#LeagueGothicRegular") format("svg");


    Jetzt kann der Browser auch deinen Font finden.

    Eine Frage ich habe dennoch, warum SSL verschlüsst? SSL belastet einen Server mehr und bringt nur wirklich einen Nutzen, dort wo Besucher persönliche Angaben machen müssen.
  10. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    all-in1 schrieb:
    Egal wo du deine Domain nachher hast, sollte es zu keinem Problem in der Darstellung der Fonts geben.

    Dein Problem ist nur die richtige Verlinkung der Fonts:

    Anstelle von:

    @font-face {
    	src: url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot");
    	src: url("font/League_Gothic-webfont.eot?#iefix") format("embedded-opentype"),
    	     url("font/League_Gothic-webfont.woff") format("woff"),
    	     url("font/League_Gothic-webfont.ttf") format("truetype"),
    	     url("font/League_Gothic-webfont.svg#LeagueGothicRegular") format("svg");


    Folgendes verwenden:

    @font-face {
    	src: url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot");
    	src: url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot?#iefix") format("embedded-opentype"),
    	     url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.woff") format("woff"),
    	     url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.ttf") format("truetype"),
    	     url("https://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.svg#LeagueGothicRegular") format("svg");


    Jetzt kann der Browser auch deinen Font finden.

    Eine Frage ich habe dennoch, warum SSL verschlüsst? SSL belastet einen Server mehr und bringt nur wirklich einen Nutzen, dort wo Besucher persönliche Angaben machen müssen.


    Ah ok, also kann ich ohne bedenken die Domain bei Strato nutzen (Wie gesagt, dort habe ich keine Datenbank)? Dann ersetze ich mal den Code, danke dir.

    Ich werde das wohl wieder wegnehmen, ich hatte vorher mal nach dem Problem gegoogelt und dort stand etwas von SSL aktivieren, geklappt hat es nicht sondern belastet nur, wie du selbst sagst.
  11. Wenn du SSL wieder deaktiviert hast, dann musst du in dem Codeschnippsel natürlich auch alles von https auf http ändern.
  12. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    Das habe ich, aber Firefox ändert das automatisch in https im Browser um.

    Mein Code sieht nun so aus und es hat sich nichts getan. Wie soll das dann auf meiner Wunschdomain bei Strato funktionieren? Ich bin einen klick davon entfernt die Domain zu nehmen oder abzulehnen. Mit der Subdomain bei lima wollte ich sehen ob ich hier das gleiche Problem habe, wie zuvor bei einer anderen Sub-domain (nicht lima)

    @font-face {
    	src: url("http://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot");
    	src: url("http://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.eot?#iefix") format("embedded-opentype"),
    	     url("http://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.woff") format("woff"),
    	     url("http://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.ttf") format("truetype"),
    	     url("http://www.swportfolio.4lima.de/wordpress2/wp-content/themes/Creativelife/font/League_Gothic-webfont.svg#LeagueGothicRegular") format("svg");
    	font-family: "LeagueGothicRegular";
    	font-weight: normal;
    	font-style: normal;


    http://swportfolio.lima-city.de/
    (Wahrscheinlich fehlt /wordpress2, sollte aber so nicht sein, das Unterverzeichnis habe ich hier bei Lima unter der Sub-Domain ausgewählt.)

    https://swportfolio.lima-city.de/wordpress2/
    Unter dieser Adresse habe ich Wordpress via FTP hochgeladen. Den Code habe ich nochmal auf diese Adresse geändert, hier nimmt er die Font auch nicht an, außer ich kehre zur bloßen Verzeichnisbeschreibung zurück.




    Beitrag zuletzt geändert: 14.9.2015 13:52:09 von swportfolio
  13. Ist doch alles OK. Sieht doch nach deinem Font aus http://www.fontsquirrel.com/fonts/league-gothic

    Auch wenn ich mir den Quelltext anschaue und die Links verfolge ist alles richtig.
  14. Also ich hab unter beiden Links von dir die schmale Font (wo du sagst es sei die richtige).

    Eventuell war es am Ende nur mehr ein Caching Problem vom Browser.
  15. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    Das mit dem Cache ist mir auch aufgefallen, aber zum ersten mal..

    Ich hab die falsch Subdomain kopiert.
    https://swportfolio.4lima.de/

    Auf meinem Handy (Safari) war bis eben die Schrift richtig. Nur nicht unter der Subdomain.

    man.., ich muss heute wissen ob ich meine com.domain bei Strato annehme oder nicht. Wenn das dort dann auch so ist :wall:

    Ich habe noch folgenden Hinweis im WP-Forum erhalten, das Lima-City die Servereinstellung so konfiguriert hat das andere Domains die Fonts nicht laden dürfen. Kann das daran liegen?



    Beitrag zuletzt geändert: 14.9.2015 18:17:52 von swportfolio
  16. Um das mit deiner Domain mal so zu sagen.

    Es ist natürlich einfacher, wenn diese bei Lima (bzw. dort ist, wo der Inhalt gehostet wird). Du brauchst nicht dann keine DNS Einträge machen und kannst auch die Subdomains dann einfacher verwalten und musst nicht auch noch dafür immer die DNS Einträge ändern.

  17. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    all-in1 schrieb:
    Um das mit deiner Domain mal so zu sagen.

    Es ist natürlich einfacher, wenn diese bei Lima (bzw. dort ist, wo der Inhalt gehostet wird). Du brauchst nicht dann keine DNS Einträge machen und kannst auch die Subdomains dann einfacher verwalten und musst nicht auch noch dafür immer die DNS Einträge ändern.



    Das stimmt, nur habe ich gerade echt bedenken das es mit dieser Domain dann genauso aussieht wie mit der Sub-Domain :( Das bereitet mir gerade ziemlich Kopfzerbrechen. Die Sub-Domain war rein zum test da, bei der eigentlichen sollte das alles reibungslos funktionieren in jedem Browser. Vielleicht liegt es wirklich an Lima selbst, puh...Ich weiss ja nicht ob es mit dieser Domain dann anders aussieht. Ich finde Lima sehr gut, aber es sollte alles reibungslos laufen.

    Beitrag zuletzt geändert: 14.9.2015 18:45:01 von swportfolio
  18. Ich habe bisher keine Probleme mit den Fonts gehabt. Nun gut mein Browser ist als Entwickler ausgerichtet, heisst ich brauche nicht für alles den Cache erst löschen, damit Änderungen gleich übernommen werden.
  19. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    all-in1 schrieb:
    Ich habe bisher keine Probleme mit den Fonts gehabt. Nun gut mein Browser ist als Entwickler ausgerichtet, heisst ich brauche nicht für alles den Cache erst löschen, damit Änderungen gleich übernommen werden.


    Was meinst du genau mit Cache löschen? vom Browser? Die Schrift sieht unter der Sub-Domain immernoch doof aus.

    Also sollte ich doch besser nach lima umziehen? Ich hoffe der Support kann auch schnell helfen, falls es mit dem Font immernoch Probleme gibt.

    Beitrag zuletzt geändert: 14.9.2015 18:57:08 von swportfolio
  20. Stimmen die Pfade denn?

    Auch auf https bzw. http geachtet?
  21. Autor dieses Themas

    swportfolio

    swportfolio hat kostenlosen Webspace.

    all-in1 schrieb:
    Stimmen die Pfade denn?

    Auch auf https bzw. http geachtet?


    Ich habe das gefühl es liegt nicht an den Pfaden :/ hab ja vorhin mal den neuen code hier eingefügt und auch http und https versucht, gleiches Ergebnis. Damit habe ich mir höchstens die Schrift unter der Orginal Adresse (Unter der ich die ganze WP geschichte hochgeladen habe) zerschossen.

    Ich habe beide Seiten nochmal unter Safari auf dem Tablet aufgerufen, dort gibt es keine Probleme mit der Schrift..., Firefox ist nach wie vor zickig

    Beitrag zuletzt geändert: 14.9.2015 20:35:29 von swportfolio
  22. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

Dir gefällt dieses Thema?

Über lima-city

Login zum Webhosting ohne Werbung!