kostenloser Webspace werbefrei: lima-city


Ubuntu: Partition ständig einhängen

lima-cityForumHeim-PCBetriebssysteme

  1. Autor dieses Themas

    werktags

    Kostenloser Webspace von werktags

    werktags hat kostenlosen Webspace.

    Wieder ein ungelöstes Problem für die Linux Spezialisten:

    Ich habe eine Partition "Eigene Dateien", welche ich von Windows XP und auch Ubuntu nutze. Das Dateisystem ist NTFS.
    Meine kompletten Musikdateien lagern auf dieser Partition. Wenn ich nun beim Start von Ubuntu meine Musikplayer öffne, würde dieser ja die Dateien vom letzten Abspielen bereithalten und ich müsste nur noch auf "Play" drücken. Jedoch gibt er mir eine Fehlermeldung aus, da dieser Datenträger nicht "eingehängt" ist. Davon gibt es noch ein paar Beispiele, die etwa aufs gleiche hinaus laufen.
    Ich habe dann gesucht und eine Anleitung gefunden. Leider scheint das bei mir nicht zu funktionieren. Entweder habe ich einen Fehler gemacht, oder es bewirkt nicht das was ich mir vorgestellt habe.

    Kann mir dabei jemand helfen?
    Es sollte doch irgendwie möglich sein, diese Partition beim Start einzuhängen und beim Beenden aus, damit ich mir diese "nervige" Arbeit sparen kann.
  2. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

  3. aldistammkunde

    Kostenloser Webspace von aldistammkunde, auf Homepage erstellen warten

    aldistammkunde hat kostenlosen Webspace.

    http://wiki.ubuntuusers.de/fstab?highlight=fstab

    dieser Artikel dürfte dir weiterhelfen.

    Kurz:
    unter (Ubuntu)-Linux gibt es die datei fstab, in der mount-informationen für alle Laufwerke, die beim Start automatisch eingebunden werden sollen, enthält. Durch hinzufügen eines entsprechenden Eintrages kannst du dort zusätzliche Laufwerke hinzufügen.
  4. q*****4

    Hallo,

    dein Freund hier heißt fstab.

    unter Linux gibt es eine Textdatei in der genau diese Automounts stehen.

    Am besten du editierst als root die Datei /etc/fstab und fügst da einen Eintrag hinzu.

    Dieser müsste ungefähr so aussehen: Device (also /dev/hda1) auf dein Gerät anpassen !
    /dev/hda1 /mnt/windows ntfs ro,user,umask=022

    ^
    Device ^ Mountpoint ^FStyp ro = readonly

    wichtig ist die TABs einzuhalten. Am besten an den vorhandenen Einträgen orientieren.

    Nach dem speichern mal mit
    mount -a
    testen. Es sollte keine Fehlermeldung auftauchen
  5. Autor dieses Themas

    werktags

    Kostenloser Webspace von werktags

    werktags hat kostenlosen Webspace.

    Erstmal Danke an euch beide!

    Nun habe ich das ja versucht. Gemäß der Anleitung und auch die Informationen über fstab geben mir keine neuen Erkenntnisse.

    Es könnte sein, dass ich da einen Fehler gemacht habe beim Schreiben in die fstab-Datei, da ich mich damit nicht sehr gut auskenne. Wie kann ich das überprüfen?
  6. kochmarkus

    Co-Admin Kostenloser Webspace von kochmarkus

    kochmarkus hat kostenlosen Webspace.

    Du könntest mal sagen, was genau du in die Datei geschrieben hast und welche Fehlermeldungen evtl. auftauchen. Auch die Ausgabe von sudo fdisk -l würde nicht schaden.
  7. Autor dieses Themas

    werktags

    Kostenloser Webspace von werktags

    werktags hat kostenlosen Webspace.

    kochmarkus schrieb: Du könntest mal sagen, was genau du in die Datei geschrieben hast und welche Fehlermeldungen evtl. auftauchen.
    Fehlermeldungen tauchen nicht auf, jedoch ist die Partition/Datenträger beim Start nicht eingehängt.
    Bild von der fstab Datei
    kochmarkus schrieb: Auch die Ausgabe von sudo fdisk -l würde nicht schaden.
    Bild von der Ausgabe
  8. kochmarkus

    Co-Admin Kostenloser Webspace von kochmarkus

    kochmarkus hat kostenlosen Webspace.

    Bist du sicher, dass die in der fstab angegebene UUID stimmt (vgl. ll /dev/disk/by-uuid/)? Außerdem ist in der Spalte <type> ntfs-3g einzutragen und nicht vfat. Und der Ordner /media/eigene_dateien muss bereits existieren (sudo mkdir /media/eigene_dateien).

    P.S. Wäre es nicht einfacher den Text zu kopieren und hier innerhalb von Code-Tags zu pasten, anstatt ein Screenshot zu machen, den wo hochzuladen und dann dir URL zu posten?

    €dit: Achja in der Spalte <pass> am Ende deiner Zeile fehlt noch ein 0. Und ich glaube nicht, dass so wie die Datei jetzt ist ein mount -a keine Fehlermeldung ergibt.

    Beitrag zuletzt geändert: 22.4.2009 16:35:42 von kochmarkus
  9. Autor dieses Themas

    werktags

    Kostenloser Webspace von werktags

    werktags hat kostenlosen Webspace.

    kochmarkus schrieb: Bist du sicher, dass die in der fstab angegebene UUID stimmt (vgl. ll /dev/disk/by-uuid/)?
    Ja.
    kochmarkus schrieb: Außerdem ist in der Spalte &lt;type&gt; ntfs-3g einzutragen und nicht vfat.
    Was ist der Unterschied? Habe es probiert, aber ohne Erfolg.
    kochmarkus schrieb: Und der Ordner /media/eigene_dateien muss bereits existieren (sudo mkdir /media/eigene_dateien).
    Ja, der existiert. Ich habe das ganze jedoch nochmal probiert und einen neuen Ordner namens "dateien" angelegt. Damit geht es auch nicht.
    kochmarkus schrieb: Achja in der Spalte &lt;pass&gt; am Ende deiner Zeile fehlt noch ein 0. Und ich glaube nicht, dass so wie die Datei jetzt ist ein mount -a keine Fehlermeldung ergibt.
    Ja, stimmt. Die 0 fehlte, hinzugefügt. Ich habe es vorher immer über Neustart (Windows Angewohntheit) gemacht.

    Jetzt habe ich deine Vorschlage übernommen und "sudo mount -a" probiert. Es kommt die Fehlermeldung:
    mount: Einhängepunkt /media/dateien    existiert nicht
    Der Ordner existiert.

    P.S. Wäre es nicht einfacher den Text zu kopieren und hier innerhalb von Code-Tags zu pasten, anstatt ein Screenshot zu machen, den wo hochzuladen und dann dir URL zu posten?
    Es wäre, jedoch hatte ich das eine Bild schon einem Bekannten geschickt, und hab mich dann entschlossen das andere auch zu machen.
    Gibt es bei den Eingaben in die fstab-Datei eine feste Anzahl von Leerzeichen zwischen den "Spalten", bzw. könnte das eine Fehlerquelle sein?

    Danke für die Mühe!
  10. der ordner muss natürlich für den einhängenden prozess beschreibbar sein, der läuft nicht mit root rechten würde ich denken, den ordner kannst du aber nur als root angelegt haben, deswegen wird es beim mounten probleme geben glaube ich

    die anzahl der leerzeichen spielt meine ich keine rolle, ich kann mich aber irren.
  11. kochmarkus

    Co-Admin Kostenloser Webspace von kochmarkus

    kochmarkus hat kostenlosen Webspace.

    Stimmt, die Anzahl der Leerzeichen macht keinen Unterschied, du kannst auch Tabs statt Leerzeichen verwenden. Kannst du vllt. mal die Ausgabe von ls -l /media posten.

    Der Unterschied zwischen vfat und ntfs-3g ist, dass vfat für FAT formatierte Datenträger ist und ntfs-3g eben für NTFS formatierte.
  12. achso:

    idealerweise sollte natürlich ntfs-3g installiert sein

    which ntfs-3g (als root)
    gibt aufschluss in diesem fall
  13. Autor dieses Themas

    werktags

    Kostenloser Webspace von werktags

    werktags hat kostenlosen Webspace.

    kochmarkus schrieb: Stimmt, die Anzahl der Leerzeichen macht keinen Unterschied, du kannst auch Tabs statt Leerzeichen verwenden. Kannst du vllt. mal die Ausgabe von ls -l /media posten.
    insgesamt 8
    lrwxrwxrwx 1 root root    6 2009-04-10 18:44 cdrom -> cdrom0
    drwxr-xr-x 2 root root 4096 2009-04-10 18:44 cdrom0
    drwxr-xr-x 2 root root 4096 2009-04-22 19:14 dateien

    Hier die geänderte aktuelle fstab Datei:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda3
    UUID=7c0b4633-adfa-4dc9-9228-e44a4e6036a5 /               ext3    relatime,errors=remount-ro 0       1
    # /dev/sda6
    UUID=3594b690-7508-48e4-8c42-042e7358b9b0 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    UUID=BE38FF1538FECC01  /media/dateien    ntfs-3g    defaults,nls=utf8,uid=1000,gid=1000,umask=007    0       0


    fatfox schrieb: idealerweise sollte natürlich ntfs-3g installiert sein
    which ntfs-3g (als root)
    gibt aufschluss in diesem fall
    Da kam lediglich das raus:
    /bin/ntfs-3g

  14. kochmarkus

    Co-Admin Kostenloser Webspace von kochmarkus

    kochmarkus hat kostenlosen Webspace.

    werktags schrieb:
    fatfox schrieb: idealerweise sollte natürlich ntfs-3g installiert sein
    which ntfs-3g (als root)
    gibt aufschluss in diesem fall
    Da kam lediglich das raus:
    /bin/ntfs-3g


    Ja, dann ist ntfs-3g installiert. ntfs-3g sollte auch bei allen aktuellen Ubuntuversionen vorinstalliert sein. Ist aber komisch, das er sagt der Einhängepunkt existiert nicht, obwohl er es tut und auch die gleichen Berechtigungen hat wie der andere Einhängepunkt. Was man noch probieren könnte, die UUID durch den normalen Devicenamen zur ersetzten (/dev/sda5), oder statt ntfs-3g den "alten" Treiber "ntfs" verwenden, der hat allerdings keine Schreibunterstützung.
  15. Autor dieses Themas

    werktags

    Kostenloser Webspace von werktags

    werktags hat kostenlosen Webspace.

    :prost: Es klappt!

    Warum kann ich nicht wirklich sagen, aber ich kann mal sagen, was ich gemacht habe. Und zwar nen Fehler. Nachdem ich das mit dem /dev/sda5 dorthin geschrieben hab, kam ne Fehlermeldung in Zeile 10. Ich habs dann wieder geändert, und dabei ist mir aufgefallen, dass die Partition "Eigene Dateien" nun komplett nicht mehr da war - einfach weg. Hab dann schnell das Backup eingefügt und dann nochmal mit mount -a probiert. Es kam keine Fehlermeldung und Eigene Dateien war drin.

    Hab mich entschlossen vorsichtshalber den Computer neuzustarten mit einer MSI Fehlermeldung. Beim zweitern Neustart, war die dann auch verschwunden. Ich hoffe sie bleibt das auch.

    Nochmal großes Lob und danke für die Mühe! :thumb:
  16. Diskutiere mit und stelle Fragen: Jetzt kostenlos anmelden!

    lima-city: Gratis werbefreier Webspace für deine eigene Homepage

Dir gefällt dieses Thema?

Über lima-city

Login zum Webhosting ohne Werbung!